Follow

Hat vlt. ein einen Rat für mich? Ich nutze Version 3.1.2 als Docker-Variante. Wenn ich versuche auf eine höhere Version upzugraden (Beispiel 3.1.3 bis 3.1.5) erhalte ich in "Eigenen Beiträgen" oder der "Lokalen Zeitleiste" einen Error 500. Hat sich in der Docker-Upgrade-Methode etwas Grundlegendes geändert? Vlt. kann mir jemand einen Tipp geben, um wenigstens auf Version 3.1.5 zu kommen.

· · Web · 1 · 1 · 0

@intux ja aber da wird es ja mehr zu geben, was sagen die Worker, was die Datenbank, die Masto Logs ? Für 500 kann vieles der Grund sein.

Von Datenbank bis zum Webserver kann da alles den Fehler verursachen.

Hast du den die jeweiligen Update Notes beachtet die zur jeder Version gehören ?

@intux @nitesparrow Hast du auch ein db:migrate gemacht, nachdem du das neue image gestartet hast?

@intux @Nico ist der sauber durchgelaufen ? Nen Error übersiehts man da mal schnell.

@nitesparrow @Nico
Naja, ich könnte das nochmals versuchen und raus kopieren. Nur dann kappe ich die Leitung. Aber ich mache das mal. 😉

@nitesparrow @intux Im Log steht, dass der Fehler von localhost:3000 kommt, also vom „web“ container.

Was gibt denn ein „docker-compose logs web“ aus?

@intux also der angehängte Log sagt eindeutig das sie nicht ohne Probleme durchlief sondern die Migration gecanceld wurde aufgrund von doppelten Einträgen die vorhanden sind.

Das selbe Problem hatten einige Instanz Admins auch ohne Docker github.com/tootsuite/mastodon/

@Nico

@intux da bin ich kein Experte für, aber aus dem Issue ist zu entnehmen das du per Postgres in der Datenbank die doppelten Einträge ausfindig machen musst und diese bereinigen musst, also einen der beiden entfernen.

Meine Postgres Kenntnisse sind aber dafür zu gering um dir da anständige Befehlsketten für liefern zu können.

@Nico

@nitesparrow @Nico
Ich danke dir erst einmal für deine Hilfe!

Sign in to participate in the conversation
CyberTerminal

CyberTerminal ein Projekt von intux.de